树状数组解法:
题意:给N段连续的球上色,求上色后每个球被涂色的次数。
思路:假设有一个数组d,令其的初值为0。若涂色 [ L,R ] 的区间,则令d [ L ] +=1;d
关于C数组和d数组的关系举个例子吧:
第一次涂 [ L,R ] 区间:
下标 1 2 3 4 5 6 7 8 9 ……
C : 0 0 1 1 1 1 0 0 0 ……
d : 0 0 1 0 0 0 -1 0 0 ……
Color the ballTime Limit: 9000/3000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 5176 Accepted Submission(s): 2747 Problem Description N个气球排成一排,从左到右依次编号为1,2,3....N.每次给定2个整数a b(a <= b),lele便为骑上他的“小飞鸽"牌电动车从气球a开始到气球b依次给每个气球涂一次颜色。但是N次以后lele已经忘记了第I个气球已经涂过几次颜色了,你能帮他算出每个气球被涂过几次颜色吗? Input 每个测试实例第一行为一个整数N,(N <= 100000).接下来的N行,每行包括2个整数a b(1 <= a <= b <= N)。 当N = 0,输入结束。 Output 每个测试实例输出一行,包括N个整数,第I个数代表第I个气球总共被涂色的次数。 Sample Input 31 12 23 331 11 21 30 Sample Output 1 1 13 2 1 Author 8600 Source |
#include <cstdio>
#include <cstring>
#define N 101000
using namespace std;
int tree[N];
int Lowbit(int x)
{
return x&(-x);
}
void Update(int pos,int val)
{
while(pos<N)
{
tree[pos]+=val;
pos+=Lowbit(pos);
}
}
int Query(int x)
{
int sum=0;
while(x>0)
{
sum+=tree[x];
x-=Lowbit(x);
}
return sum;
}
int main()
{
int n;
while(scanf("%d",&n)!=EOF&&n!=0)
{
memset(tree,0,sizeof(tree));
int a,b;
for(int i=1;i<=n;i++)
{
scanf("%d%d",&a,&b);
Update(a,1);
Update(b+1,-1);
}
for(int i=1;i<=n;i++)
{
printf("%d",Query(i));
if(i!=n) printf(" ");
}
putchar(10);
}
return 0;
}